Back to overview

Recovering from a resource exhaustion attack

Jun 5, 2026 at 10:31pm UTC
Affected services
Application
Workers

Resolved
Jun 5, 2026 at 10:31pm UTC

Earlier today, Sift experienced a database storage incident caused by a deliberately abusive user behaviour. We identified and suspended the abusive account, stopped the runaway import impact, and began removing the incident-related data. The system is now recovering while we implement hardening.